Billets taggés avec : excel


Comment sélectionner les données d'un tableau Excel avec VBA ?

Dans Excel, il est fortement conseillé de travailler avec des données structurées pour pouvoir les manipuler plus facilement (sans faire d'erreurs). Mettre des donnés dans un tableau correspond à cette methodologie (via "Mettre sous forme de tableau") : un nom de tableau est à donner, chaque variable (champ du tableau) doit avoir un nom unique. […]

table_exc

graphique-decaler

Comment créer un graphique qui prend en compte de nouvelles données ?

Si vous avez besoin de créer un graphique qui s'adapte et intègre automatiquement de nouvelles données, la solution est de passer par des  plages dynamiques en leur donnant un nom qui sera utilisé dans la configuration du graphique (valeurs de la serie). Afin de créer une plage dynamique prenant en compte les nouvelles données, il […]


mois-chiffre

Comment afficher le mois sur 2 numeros ?

Pour certains besoins, il est utile d'afficher le mois sur 2 numeros, de telle sorte que le mois de Janvier correspondra à 01 (et pas 1) et le mois de Décembre correspondra à 12. Pour cela, la fonction TEXTE() peut être utilisée. Ce qui donne par exemple: =TEXTE(MOIS(A1);"0#") où la cellule A1 contient la date […]


Pourquoi ne pas utiliser Excel comme une base de données ?

Excel est très pratique et flexible, ce qui l'amène parfois à être utilisé comme une base de données. C'est à dire à stocker dans une ou plusieurs feuilles toutes les données afin de faire des formules pour pré-calculer les données et créer les consolidations nécessaires. Cependant même si Excel peut très bien faire ce travail, […]

excel-db

pq3

Comment récupérer des données de plusieurs sources avec PowerPivot dans Excel ?

Excel permet de regrouper des données de plusieurs sources avec PowerPivot pour les fusionner dans un même tableau croisé dynamique. PowerPivot permet de dépasser les capacités d'Excel puisqu'il agit comme un logiciel en parallèle. Il permet notamment de faire appel à un volume de données très important (big data) grâce à la technologie in-memory et […]


5-ms-query

Comment faire des requetes dans une base MySQL avec Excel ?

Dans cet article, nous allons voir comment lancer une requête sur une base MySQL depuis Excel. Pour cela nous allons nous aider de MS Query. Créer une connexion ODBC Pour pouvoir permettre à Excel d’accéder directement à la base MySQL, il faut télécharger et installer le connecteur ODBC (Open Data Base Connectivity) mis à disposition […]