Comment regrouper toutes les données d'un classeur dans une seule feuille ?


Les données sont parfois rangées dans différentes feuilles d'un classeur. Et il peut être nécessaire de regrouper ces données dans une seule feuille : par exemple pour utiliser un tableau croisé dynamique.

Ceci peut être fait à l'aide de la formule INDIRECT qui permet d'aller récupérer la valeur d'une cellule dont on précise le chemin d'accès. Ainsi, en combinant les fonctions suivantes dans une formule, on peut consolider toutes les valeurs dans une seule table :

  • INDIRECT() : pour récupérer la valeur, en utilisant le style de référence L1C1 qui permet de manipuler plus facilement les references de ligne/colonne (mettre FAUX pour le 2eme critere)
  • CONCATENER() : pour construire le chemin d'accès
  • RECHERCHEV() : pour faire une table d'association si nécessaire pour récupérer le nom d'une feuille (selon des règles à définir)
  • CELLULE() pour récupérer le numéro d'une colonne ou d'une ligne
  • SIERREUR() : pour mettre 0 si il n'y a pas de valeur à récupérer (pour des cas spécifiques)

Ainsi, avec la formule suivante, on récupère la valeur de A1 dans la Feuille Feuil1 et cette formule peut être étendue :

=SIERREUR(INDIRECT(CONCATENER(RECHERCHEV(1;C1:D2;2;FAUX);"!L";CELLULE("ligne";A1);"C";CELLULE("colonne";A1));FAUX);0)

Pour + d'infos :

- Fontion Excel INDIRECT

 

5.00 avg. rating (96% score) - 1 vote

Laissez un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *