Comment utiliser sommeprod() pour faire du dénombrement avec des conditions ?


Lorsque l'on souhaite récupérer une valeur correspondant à Vrai/Faux, on pense en premier à utiliser la fonction SI(). Cette fonction peut devenir assez limitée et laborieuse lorsqu'on souhaite combiner plusieurs conditions (ET, OU).

La fonction Sommeprod() peut donc être utile. Cette fonction permet de réaliser des calculs en tenant compte de certaines conditions. Et il est également possible de l'utiliser pour récupérer les valeurs 0 ou 1 correspondant à FAUX ou VRAI. Ce qui permet ensuite de faire le denombrement (comme un COUNT en SQL).

Pour cela, il faut utiliser la fonction Sommeprod() en ajoutant à la fin "*1" pour convertir le résultat Vrai/Faux en 1 ou 0.
Les conditions ET correspondent à l'utilisation des "*". Et pour une condition OU, il est possible d'utiliser "+" (addition de fonctions), ainsi si le resultat est superieur à 0, cela correspond à VRAI.

Dans l'exemple ci-dessous,
on souhaite avoir le nombre de produits ayant un prix supérieur à 100 (colonne B contient les Prix)
Cela correspond au denombrement où Prix > 100.
=SOMMEPROD((B2:B100>100)*1)
Si on avait pas ajouté "*1), le calcul aurait renvoyé la somme des prix des produits ayant prix > 100.

Sommeprod denombrement

Pour + d'infos :
http://boisgontierjacques.free.fr/pages_site/sommeprod.htm

Comment utiliser sommeprod() pour faire du dénombrement avec des conditions ?
  • 0.00 / 5 5
0 votes, 0.00 avg. rating (0% score)

Laissez un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>